April, 2026
Incident Updates
Wednesday, April 15th
No Incidents
Thursday, April 16th
No Incidents
Friday, April 17th
RESOLVED
Network instability
Updates
- RESOLVED
The problems were caused due to a specific attack which caused load issues on some of our filter systems. We isolated the issue and everything is stable again. We apologize for the inconveniences
- INVESTIGATING
We are aware of some network instablity, we are checking the cause currently
Saturday, April 18th
No Incidents
Sunday, April 19th
No Incidents